Og CRUD naming of methods

Hi Devs

In [./manager.rb:initialize]
@store_class.allocate.destroy_db(@options) if
Og.destroy_schema||@options[:destroy]

and elsewhere there is this:

alias_method :destroy, :drop_table
alias_method :drop_schema, :drop_schema

Despite the typo (in the last alias) it seems there is confusion in
the code about whether a schema is a db or table…

Is it worth articulating following goal for Og to progress to?

To use C.R.U.D stubs to method names. so prepend:
create, read update, delete
to the following
*_db
*_table
*_row
*_field

I also think the abundance of aliases might hurt in the longer term -
it’s driving me nuts. Accepting there may be some pain to adopt these
conventions, but won’t it help to have a consistent naming convention
that you don’t have to scramble to the docs to check: 'Is it destroy,
drop, delete, table, tbl, schema, etc?"

my 2c after a frustrating few days :slight_smile:

I more or less agree with consistent naming. But, I am afraid this
will have to wait for a later version.

thanks for this useful post,
-g.

On 9/29/07, Mark Van De Vyver [email protected] wrote:

*_row
Nitro-general mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/nitro-general


http://gmosx.me.gr
http://phidz.com
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr

On second thoughts, If you have the time to go over the source code
and apply the naming conventions (while making sure that it doesnt
break everything) I could apply the patch in the current version.

-g.

On 9/29/07, George M. [email protected] wrote:

@store_class.allocate.destroy_db(@options) if
Is it worth articulating following goal for Og to progress to?
it’s driving me nuts. Accepting there may be some pain to adopt these


http://gmosx.me.gr
http://phidz.com
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr
http://nitroproject.org


http://gmosx.me.gr
http://phidz.com
http://blog.gmosx.com
http://cull.gr
http://www.joy.gr

Being all in favor of consistent naming could I still say : be careful
with this? This is no breaking news but it’s surprising how easy one
overlooks something when renaming a method. And since the test suite is
all but complete…

Ok, please carry on.

(ab)

George M. schreef:

Arne B. schreef:

Being all in favor of consistent naming could I still say : be careful
with this? This is no breaking news but it’s surprising how easy one
overlooks something when renaming a method. And since the test suite
is all but complete…
I mean : far from complete…

Hi,

good points on making a single naming schema for whole Og.

While I do think that is generally a good idea, I propose on doing
what was originally the plan for the next release:

  • Get test suite running

I’m starting to sound like a broken recording, sorry. :confused:

Jo

Hi,
On 9/30/07, Jonathan B. [email protected] wrote:

Hi,

good points on making a single naming schema for whole Og.

While I do think that is generally a good idea, I propose on doing
what was originally the plan for the next release:

  • Get test suite running

I had in mind more of an ongoing goal.
And yes, this is easier done with confidence once the specs are
complete.
At the moment I’m holding back DBI adapter commits until a large chunk
of functionality is done/settled will then send patches.

Do we invoke a rule at some point that patches only accepted with an
accompanying doc and some spec/test? If we do this then there should
be more detail on the dev. page about any style choices.

Mark